Commit 617ec6c5 authored by Mauro Bender's avatar Mauro Bender
Browse files

Add code coverage information

parent c1829f89
...@@ -7,7 +7,8 @@ build_code: ...@@ -7,7 +7,8 @@ build_code:
- cd Example/ - cd Example/
- bundle install - bundle install
- bundle exec pod install - bundle exec pod install
- bundle exec scan --scheme Api-Example - bundle exec scan --scheme Api-Example --code_coverage --derived_data_path build
- bundle exec slather coverage -s --scheme Api-Example --workspace Api.xcworkspace --build-directory build --binary-basename Api Api.xcodeproj
tags: tags:
- ios - ios
artifacts: artifacts:
......
...@@ -34,13 +34,28 @@ ...@@ -34,13 +34,28 @@
ReferencedContainer = "container:Api.xcodeproj"> ReferencedContainer = "container:Api.xcodeproj">
</BuildableReference> </BuildableReference>
</BuildActionEntry> </BuildActionEntry>
<BuildActionEntry
buildForTesting = "YES"
buildForRunning = "YES"
buildForProfiling = "YES"
buildForArchiving = "YES"
buildForAnalyzing = "YES">
<BuildableReference
BuildableIdentifier = "primary"
BlueprintIdentifier = "FEA2BAA9368CEF9B0243D288F81759E9"
BuildableName = "Api.framework"
BlueprintName = "Api"
ReferencedContainer = "container:Pods/Pods.xcodeproj">
</BuildableReference>
</BuildActionEntry>
</BuildActionEntries> </BuildActionEntries>
</BuildAction> </BuildAction>
<TestAction <TestAction
buildConfiguration = "Debug" buildConfiguration = "Debug"
selectedDebuggerIdentifier = "Xcode.DebuggerFoundation.Debugger.LLDB" selectedDebuggerIdentifier = "Xcode.DebuggerFoundation.Debugger.LLDB"
selectedLauncherIdentifier = "Xcode.DebuggerFoundation.Launcher.LLDB" selectedLauncherIdentifier = "Xcode.DebuggerFoundation.Launcher.LLDB"
shouldUseLaunchSchemeArgsEnv = "YES"> shouldUseLaunchSchemeArgsEnv = "YES"
codeCoverageEnabled = "YES">
<Testables> <Testables>
<TestableReference <TestableReference
skipped = "NO"> skipped = "NO">
......
...@@ -4,3 +4,4 @@ source "https://rubygems.org" ...@@ -4,3 +4,4 @@ source "https://rubygems.org"
gem 'cocoapods', git: 'https://github.com/CocoaPods/CocoaPods.git' gem 'cocoapods', git: 'https://github.com/CocoaPods/CocoaPods.git'
gem 'fastlane' gem 'fastlane'
gem 'slather'
...@@ -36,6 +36,7 @@ GEM ...@@ -36,6 +36,7 @@ GEM
fastlane_core (>= 0.29.1, < 1.0.0) fastlane_core (>= 0.29.1, < 1.0.0)
spaceship (>= 0.22.0, < 1.0.0) spaceship (>= 0.22.0, < 1.0.0)
claide (1.0.0) claide (1.0.0)
clamp (0.6.5)
cocoapods-core (1.1.0.beta.1) cocoapods-core (1.1.0.beta.1)
activesupport (>= 4.0.2) activesupport (>= 4.0.2)
fuzzy_match (~> 2.0.4) fuzzy_match (~> 2.0.4)
...@@ -189,6 +190,7 @@ GEM ...@@ -189,6 +190,7 @@ GEM
mime-types-data (~> 3.2015) mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521) mime-types-data (3.2016.0521)
mini_magick (4.5.1) mini_magick (4.5.1)
mini_portile2 (2.1.0)
minitest (5.9.0) minitest (5.9.0)
molinillo (0.5.0) molinillo (0.5.0)
multi_json (1.12.1) multi_json (1.12.1)
...@@ -199,6 +201,9 @@ GEM ...@@ -199,6 +201,9 @@ GEM
net-ssh (>= 2.6.5) net-ssh (>= 2.6.5)
net-ssh (3.2.0) net-ssh (3.2.0)
netrc (0.7.8) netrc (0.7.8)
nokogiri (1.6.8)
mini_portile2 (~> 2.1.0)
pkg-config (~> 1.1.7)
os (0.9.6) os (0.9.6)
pem (1.3.2) pem (1.3.2)
fastlane_core (>= 0.43.1, < 1.0.0) fastlane_core (>= 0.43.1, < 1.0.0)
...@@ -208,6 +213,7 @@ GEM ...@@ -208,6 +213,7 @@ GEM
fastlane_core (>= 0.46.2, < 1.0.0) fastlane_core (>= 0.46.2, < 1.0.0)
spaceship (>= 0.29.0, < 1.0.0) spaceship (>= 0.29.0, < 1.0.0)
terminal-table (~> 1.4.5) terminal-table (~> 1.4.5)
pkg-config (1.1.7)
plist (3.1.0) plist (3.1.0)
produce (1.2.0) produce (1.2.0)
fastlane_core (>= 0.30.0, < 1.0.0) fastlane_core (>= 0.30.0, < 1.0.0)
...@@ -236,6 +242,11 @@ GEM ...@@ -236,6 +242,11 @@ GEM
jwt (~> 1.5) jwt (~> 1.5)
multi_json (~> 1.10) multi_json (~> 1.10)
slack-notifier (1.5.1) slack-notifier (1.5.1)
slather (2.3.0)
activesupport (>= 4.0.2, < 5)
clamp (~> 0.6)
nokogiri (~> 1.6.3)
xcodeproj (>= 0.20, < 2.0.0)
snapshot (1.14.0) snapshot (1.14.0)
fastimage (~> 1.6.3) fastimage (~> 1.6.3)
fastlane_core (>= 0.50.3, < 1.0.0) fastlane_core (>= 0.50.3, < 1.0.0)
...@@ -283,6 +294,7 @@ PLATFORMS ...@@ -283,6 +294,7 @@ PLATFORMS
DEPENDENCIES DEPENDENCIES
cocoapods! cocoapods!
fastlane fastlane
slather
BUNDLED WITH BUNDLED WITH
1.12.5 1.12.5
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment